Edge Theory Labs Help Center logo
Edge Theory Labs Help Center logo

All articles

Water Circulation Troubleshooting GuideUpdated 5 months ago

When the screen is flashing the software version (1.X or 2.X), this means the unit is priming the system with water for circulation. This screen is normal to see and establishing water circulation can take up to 3 minutes, especially if the hoses and/or machine were recently drained of water. 

If your Edge Chiller is experiencing issues with establishing water circulation, or the screen is flashing the software version (e.g. 1.8 or 2.0), please use the following steps to diagnose and resolve. We have found that these steps resolve the majority of water circulation issues.

  1. Be sure that the valves on your tub connections are open, and even if the filter and strainer elements have been recently changed, please replace them anyway for troubleshooting.

  2. Check the filter housing connection. This can cross thread and if so, this will allow air into the water flow preventing the unit to have the ability to start cooling or heating water. Simply removing the water filter housing and reconnecting can solve this issue. The water filter housing should thread on smoothly with minimal resistance.

  3. Check the strainer cover o-ring and connection. This should be firmly hand-tightened. If loose, this will allow air into the water flow preventing the unit to have the ability to start cooling or heating water. 

  4. Check to see if bubbles are occurring in the tub from the green tub inlet port. If they are not, ensure the check valve inside the outlet port (green port on the chiller) is not stuck open. The check valve can become stuck and prevent the system from priming air out of the chiller. This can happen after doing routine maintenance and is easy to resolve. Using a narrow pointed tool, simply press the center “cross” section of the valve back inward. It does not need to be pressed hard, just enough to move back into position.

Lastly, if all above does not successfully resolve the issue, try removing the water filter from the water filter housing, fill with water, and reinstall. If the chiller runs without the filter, please advise this to the Edge team for additional guidance.

If the steps above do not resolve the problem, please contact [email protected] so that we can further assist you! 

Was this article helpful?
Yes
No